Changes to EBSCO's Minimum Browser Requirements

June 9, 2016

As of July 2017, EBSCO will no longer be providing support for Internet Explorer 8.0 or 9.0. Until then, all existing functionality that is currently supported in IE 8.0 and 9.0 will continue to be supported; however, new services and features released after May 2016 will only be supported in IE 10.0 or higher.

Please visit the vendor's website for more information and a list of current minimum browser requirements for EBSCO.

From the vendor:

In an effort to provide the best possible service for your EBSCO subscriptions and services, we are making adjustments to our supported browsers. Beginning in July 2017, we will no longer support Internet Explorer 8.0 or 9.0 due to security risks.To avoid any service interruptions, please make all recommended browser updates before July 2017.

We recognize that many of our customers need advanced notice, and we will work with you to ensure that this transition is seemless for you and your users.

Share: